You can't log in because of a "Missing Encryption Key" error.


Cause

  • Windward tables can be encrypted typically for PCI purposes to protect credit card information. We do allow the entire database to be encrypted or just selected tables. For a user to be able to access or login, you must have an “Encryption Key”. 


You must be doing either of both:

  • Install on a new machine
  • Doing testing on your end using a customer data copy


Solution

You will need to contact the customer and get the Encryption Keys from “any” of their computers.


  • Login to SystemFive with administrative privileges
  • Go to Setup Wizard
  • Payment Processing
  • on the right side box, select Credit Card Info Tab
  • Click on PCI Compliance Check (in blue)
  • Click on the Key Management button (last one)
  • on the new box that opens, go to File menu / Export
  • save the .WKF file on the desktop or anywhere you want
  • it might attempt to send a separate copy via email, you can cancel that
  • To exit out of the window


  • go back to File Menu and click on Exit
  • Click the NO button for the PCI Check box
  • and logout of Systemfive



For System Five on Cloud this is stored in an INI file instead of the registry.